Un changement important est apparu dans le format de compression des RPMs, qui passe ainsi de GZIP à XZ (nouveau format de compression LZMA). Il faut donc avant toute tentative de mise à jour vers la rawhide faire en sorte que votre système sache prendre en compte ce nouveau type de RPMs. Sans quoi vous aurez ce genre d'erreurs:

rpmlib(PayloadIsXz) <= 5.2-1 is needed by <blop>

Avant d'activer le dépot RawHide, il faut mettre à jour rpm grâce au dépot updates-testing:

yum --enablerepo=updates-testing update rpm

A partir de là, vous pouvez activer le dépôt RawHide et mettre à jour votre système avec un bon gros "yum update".

Pour information, le nouveau format de compression XZ est censé apporter les mêmes avantages que la compression BZIP2 sans la forte utilisation CPU lors de la décompression (uniquement). Donc en théorie un gain de temps et d'espace lors des mises à jour, a voir... Et pour plus d'information: https://fedoraproject.org/wiki/Features/XZRpmPayloads